blob: 776191847c3ed34d0733c2178a12cd4f11ea6eb6 [file] [log] [blame]
developer930b9e52022-04-15 15:55:45 +08001SUMMARY = "An program to read/write from/to a pci device from userspace"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
developer930b9e52022-04-15 15:55:45 +08006SRC_URI = " \
developerca4a9f62022-11-03 17:43:30 +08007 file://COPYING;subdir=git/src \
8 file://src;subdir=git \
developer930b9e52022-04-15 15:55:45 +08009 "
10
developerca4a9f62022-11-03 17:43:30 +080011S = "${WORKDIR}/git/src"
12
developer930b9e52022-04-15 15:55:45 +080013do_compile() {
14 ${CC} ${CFLAGS} ${LDFLAGS} regs.c -o regs
15}
16
17do_install() {
18 install -d ${D}${base_bindir}
developerca4a9f62022-11-03 17:43:30 +080019 install -m 0755 ${S}/regs ${D}${base_bindir}
developer930b9e52022-04-15 15:55:45 +080020}