developer | bc262d5 | 2022-06-27 19:47:13 +0800 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # ubus_git.bbappend |
| 4 | # |
| 5 | # Copyright (c) 2013-2021 Inango Systems LTD. |
| 6 | # |
| 7 | # Author: Inango Systems LTD. <support@inango-systems.com> |
| 8 | # Creation Date: 20 Feb 2021 |
| 9 | # |
| 10 | # The author may be reached at support@inango-systems.com |
| 11 | # |
| 12 | # Redistribution and use in source and binary forms, with or without modification, |
| 13 | # are permitted provided that the following conditions are met: |
| 14 | # |
| 15 | # 1. Redistributions of source code must retain the above copyright notice, |
| 16 | # this list of conditions and the following disclaimer. |
| 17 | # |
| 18 | # 2. Redistributions in binary form must reproduce the above copyright notice, |
| 19 | # this list of conditions and the following disclaimer in the documentation |
| 20 | # and/or other materials provided with the distribution. |
| 21 | # |
| 22 | # Subject to the terms and conditions of this license, each copyright holder |
| 23 | # and contributor hereby grants to those receiving rights under this license |
| 24 | # a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable |
| 25 | # (except for failure to satisfy the conditions of this license) patent license |
| 26 | # to make, have made, use, offer to sell, sell, import, and otherwise transfer |
| 27 | # this software, where such license applies only to those patent claims, already |
| 28 | # acquired or hereafter acquired, licensable by such copyright holder or contributor |
| 29 | # that are necessarily infringed by: |
| 30 | # |
| 31 | # (a) their Contribution(s) (the licensed copyrights of copyright holders and |
| 32 | # non-copyrightable additions of contributors, in source or binary form) alone; |
| 33 | # or |
| 34 | # |
| 35 | # (b) combination of their Contribution(s) with the work of authorship to which |
| 36 | # such Contribution(s) was added by such copyright holder or contributor, if, |
| 37 | # at the time the Contribution is added, such addition causes such combination |
| 38 | # to be necessarily infringed. The patent license shall not apply to any other |
| 39 | # combinations which include the Contribution. |
| 40 | # |
| 41 | # Except as expressly stated above, no rights or licenses from any copyright |
| 42 | # holder or contributor is granted under this license, whether expressly, by |
| 43 | # implication, estoppel or otherwise. |
| 44 | # |
| 45 | # DISCLAIMER |
| 46 | # |
| 47 | # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" |
| 48 | # AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE |
| 49 | # IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE |
| 50 | # ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE |
| 51 | # LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL |
| 52 | # DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR |
| 53 | # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER |
| 54 | # CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, |
| 55 | # OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE |
| 56 | # USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
| 57 | # |
| 58 | # NOTE |
| 59 | # |
| 60 | # This is part of a management middleware software package called MMX that was developed by Inango Systems Ltd. |
| 61 | # |
| 62 | # This version of MMX provides web and command-line management interfaces. |
| 63 | # |
| 64 | # Please contact us at Inango at support@inango-systems.com if you would like to hear more about |
| 65 | # - other management packages, such as SNMP, TR-069 or Netconf |
| 66 | # - how we can extend the data model to support all parts of your system |
| 67 | # - professional sub-contract and customization services |
| 68 | # |
| 69 | ################################################################################ |
| 70 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" |
| 71 | |
| 72 | inherit ${@d.getVar('DISTRO', True) == 'rdk' and 'systemd' or 'base'} |
| 73 | |
| 74 | SRC_URI_append_rdk += "\ |
| 75 | file://ubusd.service \ |
| 76 | " |
| 77 | |
| 78 | SYSTEMD_SERVICE_${PN}_rdk = "ubusd.service" |
| 79 | |
| 80 | do_install_append_rdk() { |
| 81 | # Install systemd unit files |
| 82 | install -d ${D}${systemd_unitdir}/system |
| 83 | install -m 0644 ${WORKDIR}/ubusd.service ${D}${systemd_unitdir}/system |
| 84 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ |
| 85 | ${D}${systemd_unitdir}/system/ubusd.service |
| 86 | } |