developer | f0fd705 | 2023-08-14 20:23:42 +0800 | [diff] [blame] | 1 | SUMMARY = "C bindings for apps which will manipulate JSON data" |
| 2 | DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C." |
| 3 | HOMEPAGE = "https://github.com/json-c/json-c/wiki" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2" |
| 6 | |
| 7 | SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \ |
| 8 | " |
| 9 | SRC_URI[md5sum] = "55f395745ee1cb3a4a39b41636087501" |
| 10 | SRC_URI[sha256sum] = "b8d80a1ddb718b3ba7492916237bbf86609e9709fb007e7f7d4322f02341a4c6" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" |
| 13 | UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+" |
| 14 | |
| 15 | RPROVIDES_${PN} = "libjson" |
| 16 | |
| 17 | inherit cmake |
| 18 | |
| 19 | EXTRA_OECONF = "--disable-werror" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |