blob: 87c5b3723f8f1d776f1dad9d966c1cf25a9814c0 [file] [log] [blame]
SUMMARY = "Marvell Ethernet firmware files"
DESCRIPTION = "Firmware for Marvell AQR113C. "
LICENSE = "CLOSED"
SRC_URI = "file://Rhe-05.06-Candidate7-AQR_Mediatek_23B_StartOff_ID45623_VER36657.cld"
S = "${WORKDIR}"
inherit allarch
do_install() {
install -d ${D}/${base_libdir}/firmware/
install -m 644 ${WORKDIR}/Rhe-05.06-Candidate7-AQR_Mediatek_23B_StartOff_ID45623_VER36657.cld ${D}${base_libdir}/firmware/
}
FILES_${PN} += "${base_libdir}/firmware/Rhe-05.06-Candidate7-AQR_Mediatek_23B_StartOff_ID45623_VER36657.cld"
# Make marvell-eth-firmware depend on all of the split-out packages.
python populate_packages_prepend () {
firmware_pkgs = oe.utils.packages_filter_out_system(d)
d.appendVar('RDEPENDS_marvell-eth-firmware', ' ' + ' '.join(firmware_pkgs))
}