blob: b2ed091b4d96ae9b7f332ab9a24f08deae01cca4 [file] [log] [blame]
developer15a43312022-04-12 11:23:23 +08001inherit rdk-image
2
3IMAGE_FEATURES_remove = "read-only-rootfs"
4
5SYSTEMD_TOOLS = "systemd-analyze systemd-bootchart"
6# systemd-bootchart doesn't currently build with musl libc
7SYSTEMD_TOOLS_remove_libc-musl = "systemd-bootchart"
8
9IMAGE_INSTALL += " packagegroup-turris-core \
10 ${SYSTEMD_TOOLS} \
11 linux-mac80211 \
12 kernel-module-compat \
13 kernel-module-cfg80211 \
14 kernel-module-mac80211 \
15 linux-mt76 \
16 kernel-module-mt76 \
17 kernel-module-mt7915e \
developer15a43312022-04-12 11:23:23 +080018 network-hotplug \
19 libmcrypt \
20 bzip2 \
21 libpcap \
22 tcpdump \
23 ebtables \
24 iw \
25 ethtool \
26 bc \
27 mesh-agent \
28 openvswitch \
29 opensync \
30 "
31
32BB_HASH_IGNORE_MISMATCH = "1"
33IMAGE_NAME[vardepsexclude] = "DATETIME"
34
35#ESDK-CHANGES
36do_populate_sdk_ext_prepend() {
37 builddir = d.getVar('TOPDIR')
38 if os.path.exists(builddir + '/conf/templateconf.cfg'):
39 with open(builddir + '/conf/templateconf.cfg', 'w') as f:
40 f.write('meta/conf\n')
41}
42
43sdk_ext_postinst_append() {
44 echo "ln -s $target_sdk_dir/layers/openembedded-core/meta-rdk $target_sdk_dir/layers/openembedded-core/../meta-rdk \n" >> $env_setup_script
45}
46
47PRSERV_HOST = "localhost:0"
48INHERIT += "buildhistory"
49BUILDHISTORY_COMMIT = "1"
50
51
52
53require image-exclude-files.inc
54
55remove_unused_file() {
56 for i in ${REMOVED_FILE_LIST} ; do rm -rf ${IMAGE_ROOTFS}/$i ; done
57}
58
59ROOTFS_POSTPROCESS_COMMAND_append = "remove_unused_file; "