[rdkb][common][bsp][Refactor BB files for kirkstone build pass]
[Description]
Refactor BB files for kirkstone build pass
[Release-log]
Change-Id: I35215ebae97282ea7c3439abe5a76d90e4322bf7
diff --git a/recipes-ccsp/util/utopia.bbappend b/recipes-ccsp/util/utopia.bbappend
index 3f011eb..70da4c4 100644
--- a/recipes-ccsp/util/utopia.bbappend
+++ b/recipes-ccsp/util/utopia.bbappend
@@ -4,7 +4,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-EXTRA_OECONF_append = " --with-ccsp-arch=arm"
+EXTRA_OECONF_append_dunfell = " --with-ccsp-arch=arm"
EXTRA_OECONF_remove = "--with-ccsp-platform=bcm"
SRC_URI_append = " \
@@ -14,7 +14,7 @@
file://0004-enable-sshd-by-default-at-bootup.patch;apply=no \
file://service_bridge_mtk.sh \
"
-SRC_URI_append_dunfell = "file://0001-Work-around-for-brlan0-issue.patch;apply=no"
+SRC_URI_append = "file://0001-Work-around-for-brlan0-issue.patch;apply=no"
SRC_URI += "file://posix-gwprovapp.patch;apply=no"
#This patch will add dummy swctl api which is originally given by brcm for XB3.
@@ -52,7 +52,7 @@
fi
}
-do_filogic_patches-append_dunfell() {
+do_filogic_patches-append() {
cd ${S}
if [ ! -e dunfell_filogic_patch_applied ]; then
patch -p1 < ${WORKDIR}/0001-Work-around-for-brlan0-issue.patch