[RDKB: add bridge mode feature]
[Description]
Add bridge mode feature
Refer to service_bridge_rpi.sh
dmcli eRT setv Device.X_CISCO_COM_DeviceControl.LanManagementEntry.1.LanMode string bridge-static
[Release-log]
diff --git a/recipes-ccsp/util/utopia.bbappend b/recipes-ccsp/util/utopia.bbappend
index 3cdc0e6..3f011eb 100644
--- a/recipes-ccsp/util/utopia.bbappend
+++ b/recipes-ccsp/util/utopia.bbappend
@@ -12,6 +12,7 @@
file://0003-remove-autoconf.patch;apply=no \
file://system_defaults \
file://0004-enable-sshd-by-default-at-bootup.patch;apply=no \
+ file://service_bridge_mtk.sh \
"
SRC_URI_append_dunfell = "file://0001-Work-around-for-brlan0-issue.patch;apply=no"
@@ -113,7 +114,7 @@
install -m 755 ${S}/source/scripts/init/system/need_wifi_default.sh ${D}${sysconfdir}/utopia/
touch ${D}${sysconfdir}/dhcp_static_hosts
#filogic uses default service_bridge.sh for now
- install -m 755 ${S}/source/scripts/init/service.d/service_bridge.sh ${D}${sysconfdir}/utopia/service.d/service_bridge.sh
+ install -m 755 ${WORKDIR}/service_bridge_mtk.sh ${D}${sysconfdir}/utopia/service.d/service_bridge.sh
install -m 755 ${WORKDIR}/dhcp_script.sh ${D}${sysconfdir}/