[rdkb][common][config][Refactor filogic880.conf and image bbappend]

[Description]
1. add efuse-tools feature to decide build in efuse tools or not
2. add dmsetup tools for firmware upgrade on secure boot

[Release-log]

diff --git a/recipes-core/images/rdk-generic-broadband-image.bbappend b/recipes-core/images/rdk-generic-broadband-image.bbappend
index f8c7577..cf8b46b 100644
--- a/recipes-core/images/rdk-generic-broadband-image.bbappend
+++ b/recipes-core/images/rdk-generic-broadband-image.bbappend
@@ -45,12 +45,13 @@
     ${@bb.utils.contains('DISTRO_FEATURES','emmc','e2fsprogs f2fs-tools','',d)} \
     util-linux-blkid \
     util-linux-blockdev \
+    ${@bb.utils.contains('DISTRO_FEATURES','secure_boot','dmsetup','',d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES','efuse_tools','mtk-efuse-nl-drv mtk-efuse-nl-tool','',d)} \
     "
 #IMAGE_INSTALL += " opensync openvswitch mesh-agent e2fsprogs "
 
 IMAGE_INSTALL_append_mt7988 += " marvell-eth-firmware "
 
-#IMAGE_INSTALL_append_secureboot += " mtk-efuse-nl-drv mtk-efuse-nl-tool "
 
 BB_HASH_IGNORE_MISMATCH = "1"
 IMAGE_NAME[vardepsexclude] = "DATETIME"