blob: 853e9741b82307a93bf7d2d77b2540f7ae0f1a48 [file] [log] [blame]
developer0447f742022-10-31 14:57:29 +08001DESCRIPTION = "mt76-test"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://../COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
6DEPENDS += "libnl-tiny"
7
8inherit pkgconfig cmake
9
10PV = "1.0"
11
12require mt76.inc
developer327aa322023-07-10 13:49:56 +080013
developer0447f742022-10-31 14:57:29 +080014SRC_URI = " \
15 git://git@github.com/openwrt/mt76.git;protocol=https \
16 file://COPYING;subdir=git \
developer5f4cfb12022-12-15 16:48:11 +080017 file://5000-mt76-add-internal-wed_tiny-header-file.patch;apply=no\
developer0447f742022-10-31 14:57:29 +080018 "
19
20
developere6cee7d2022-11-16 18:00:20 +080021
22
developer0447f742022-10-31 14:57:29 +080023DEPENDS += "virtual/kernel"
24DEPENDS += "linux-mac80211"
25DEPENDS += "linux-mt76"
26
developer93e97202024-01-17 12:29:44 +080027FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
developer0447f742022-10-31 14:57:29 +080028
29
30CFLAGS_append = " -I=${includedir}/libnl-tiny "
31
32S = "${WORKDIR}/git/tools"
developer93e97202024-01-17 12:29:44 +080033PATCH_SRC = "${@bb.utils.contains('DISTRO_FEATURES','wifi_eht','${WORKDIR}/patches-3.x','${WORKDIR}/patches',d)}"
developer0447f742022-10-31 14:57:29 +080034
developer93e97202024-01-17 12:29:44 +080035SRC_URI += "file://${@bb.utils.contains('DISTRO_FEATURES','wifi_eht','patches-3.x/','patches/',d)};apply=no"
developer0447f742022-10-31 14:57:29 +080036
developer0447f742022-10-31 14:57:29 +080037do_mtk_patches() {
38 cd ${S}/../
developere6cee7d2022-11-16 18:00:20 +080039
developer0447f742022-10-31 14:57:29 +080040 if [ ! -e mtk_wifi_patch_applied ]; then
developer93e97202024-01-17 12:29:44 +080041 for i in ${PATCH_SRC}/*.patch; do patch -p1 < $i; done
developer0447f742022-10-31 14:57:29 +080042 fi
43 touch mtk_wifi_patch_applied
44}
45addtask mtk_patches after do_patch before do_configure
46
47
48
49
50
51