blob: a16e0d663f215d99ba733d6cbf676c3178938e5d [file] [log] [blame]
developer880c8292022-07-11 11:52:59 +08001SUMMARY = "Command to config switch"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
developer880c8292022-07-11 11:52:59 +08006
7DEPENDS = "libnl"
8
9SRC_URI = " \
developer5dfa8b72022-11-03 11:33:07 +080010 file://COPYING;subdir=git/src \
11 file://src;subdir=git \
12 file://rdkb-change-bridge-name.patch \
developer880c8292022-07-11 11:52:59 +080013 "
14
developer5dfa8b72022-11-03 11:33:07 +080015S = "${WORKDIR}/git/src"
16
developer880c8292022-07-11 11:52:59 +080017CFLAGS_prepend = " \
18 -D_GNU_SOURCE \
19 -I${STAGING_INCDIR}/libnl3 \
20 -I${S} \
21 "
22
23do_compile() {
24 oe_runmake -C ${S} "LIBS=-L${STAGING_LIBDIR} -lnl-3 -lnl-genl-3 -lm"
25}
26
27do_install() {
28 install -d ${D}/usr/sbin
developer5dfa8b72022-11-03 11:33:07 +080029 install -m 0755 ${S}/switch ${D}/usr/sbin
developer880c8292022-07-11 11:52:59 +080030}