blob: e05e6b778e6389e1c0e54539dd46ab8529343a24 [file] [log] [blame]
developer33759cf2024-10-11 15:19:50 +08001SUMMARY = "Airoha Ethernet firmware files"
2DESCRIPTION = "Firmware for Airoha 2.5G phy. "
3
4LICENSE = "CLOSED"
5
6SRC_URI = " \
7 file://EthMD32.dm.bin \
8 file://EthMD32.DSP.bin \
9"
10S = "${WORKDIR}"
11
12inherit allarch
13
14do_install() {
15 install -d ${D}/${base_libdir}/firmware/
16 install -m 644 ${WORKDIR}/EthMD32.dm.bin ${D}${base_libdir}/firmware/
17 install -m 644 ${WORKDIR}/EthMD32.DSP.bin ${D}${base_libdir}/firmware/
18}
19
20FILES_${PN} += "${base_libdir}/firmware/*"
21
22# Make Mediatek-eth-firmware depend on all of the split-out packages.
23python populate_packages_prepend () {
24 firmware_pkgs = oe.utils.packages_filter_out_system(d)
25 d.appendVar('RDEPENDS_mediatek-eth-firmware', ' ' + ' '.join(firmware_pkgs))
26}