blob: 88d250a303cd8faf6144d8d7bf7f402c12e147a0 [file] [log] [blame]
developer0447f742022-10-31 14:57:29 +08001DESCRIPTION = "mt76-test"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://../COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
developer05f3b2b2024-08-19 19:17:34 +08006DEPENDS += "libnl-tiny linux-mac80211"
developer0447f742022-10-31 14:57:29 +08007
8inherit pkgconfig cmake
9
10PV = "1.0"
11
12require mt76.inc
developera20cdc22024-05-31 18:57:31 +080013require mt76-3x.inc
developer327aa322023-07-10 13:49:56 +080014
developer0447f742022-10-31 14:57:29 +080015SRC_URI = " \
16 git://git@github.com/openwrt/mt76.git;protocol=https \
17 file://COPYING;subdir=git \
developer5f4cfb12022-12-15 16:48:11 +080018 file://5000-mt76-add-internal-wed_tiny-header-file.patch;apply=no\
developer0447f742022-10-31 14:57:29 +080019 "
20
21
developere6cee7d2022-11-16 18:00:20 +080022
23
developer0447f742022-10-31 14:57:29 +080024DEPENDS += "virtual/kernel"
25DEPENDS += "linux-mac80211"
26DEPENDS += "linux-mt76"
27
developer93e97202024-01-17 12:29:44 +080028FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
developer0447f742022-10-31 14:57:29 +080029
30
developer05f3b2b2024-08-19 19:17:34 +080031CFLAGS_append = " -I=${includedir}/libnl-tiny -I${STAGING_KERNEL_BUILDDIR}/usr/include/mac80211/uapi "
developer0447f742022-10-31 14:57:29 +080032
33S = "${WORKDIR}/git/tools"
developer93e97202024-01-17 12:29:44 +080034PATCH_SRC = "${@bb.utils.contains('DISTRO_FEATURES','wifi_eht','${WORKDIR}/patches-3.x','${WORKDIR}/patches',d)}"
developer0447f742022-10-31 14:57:29 +080035
developer93e97202024-01-17 12:29:44 +080036SRC_URI += "file://${@bb.utils.contains('DISTRO_FEATURES','wifi_eht','patches-3.x/','patches/',d)};apply=no"
developerfd901d92024-04-29 17:16:53 +080037SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES','wifi_eht','file://0118-fixup-wifi-mt76-mt7996-temp-support-for-single-wiphy.patch;subdir=${PATCH_SRC};apply=no','',d)}"
developer0447f742022-10-31 14:57:29 +080038
developer0447f742022-10-31 14:57:29 +080039do_mtk_patches() {
40 cd ${S}/../
developere6cee7d2022-11-16 18:00:20 +080041
developer0447f742022-10-31 14:57:29 +080042 if [ ! -e mtk_wifi_patch_applied ]; then
developer93e97202024-01-17 12:29:44 +080043 for i in ${PATCH_SRC}/*.patch; do patch -p1 < $i; done
developer0447f742022-10-31 14:57:29 +080044 fi
45 touch mtk_wifi_patch_applied
46}
47addtask mtk_patches after do_patch before do_configure
48
49
50
51
52
53