[rdkb][common][app][Refactor regs and mtk-factory-rw tools]
[Description]
Refactor regs and mtk-factory-rw tools
[Release-log]
Change-Id: Ifcaece41f2fe204fbc6804e659ea78160a86f041
diff --git a/recipes-devtools/regs/regs_1.0.bb b/recipes-devtools/regs/regs_1.0.bb
index 80666fa..7761918 100644
--- a/recipes-devtools/regs/regs_1.0.bb
+++ b/recipes-devtools/regs/regs_1.0.bb
@@ -3,18 +3,18 @@
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
-S = "${WORKDIR}"
-
SRC_URI = " \
- file://COPYING \
- file://regs.c \
+ file://COPYING;subdir=git/src \
+ file://src;subdir=git \
"
+S = "${WORKDIR}/git/src"
+
do_compile() {
${CC} ${CFLAGS} ${LDFLAGS} regs.c -o regs
}
do_install() {
install -d ${D}${base_bindir}
- install -m 0755 ${WORKDIR}/regs ${D}${base_bindir}
+ install -m 0755 ${S}/regs ${D}${base_bindir}
}