[rdkb][mt7988][bsp][Add filogic 880 system init]
[Description]
Add filogic 880 system init
1. add THREE_GMACS_SUPPORT flag for hal-ethsw
2. init-bridge and init-MacAddr support three GMACS
[Release-log]
diff --git a/recipes-ccsp/hal/hal-ethsw-generic_git.bbappend b/recipes-ccsp/hal/hal-ethsw-generic_git.bbappend
index c50feee..4f9c9ed 100644
--- a/recipes-ccsp/hal/hal-ethsw-generic_git.bbappend
+++ b/recipes-ccsp/hal/hal-ethsw-generic_git.bbappend
@@ -4,6 +4,8 @@
CFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'rdkb_wan_manager', ' -DFEATURE_RDKB_WAN_MANAGER ', '', d)}"
+CFLAGS_append_mt7988 = " -DTHREE_GMACS_SUPPORT"
+
do_configure_prepend(){
if ${@bb.utils.contains('DISTRO_FEATURES','switch_gsw_mode','true','false',d)}; then
ln -sf ${S}/rdkb_hal/src/ethsw/ccsp_hal_ethsw_gsw.c ${S}/ccsp_hal_ethsw.c