[rdkb][common][bsp][Refactor and sync wifi from openwrt]

[Description]
93c9497 [MAC80211][mt76][Fix mwctl set hostapd_cli cmd]
a737b23 [mac80211][mt76][Fix backports6.1 build fail]
5423240 [MAC80211][hostapd][Fix HOSTAPD_START_FAILED caused by ubus]
b5e1c3b [MAC80211][mt76][5G UNII4 support]
27b4e6a [MAC80211][mt76][Add the MURU definition for test mode]
0d84ee7 [MAC80211][hostapd][Fix STA association failure when co-locating with multiple AP interfaces]
4afd899 [MT76][Fix mt7915 Air-Monitor issue]

[Release-log]

Change-Id: Id48a094923b83de8650eebf6004b498b12a481d6
diff --git a/recipes-wifi/wireless-regdb/wireless-regdb_2023.05.03.bb b/recipes-wifi/wireless-regdb/wireless-regdb_2023.05.03.bb
new file mode 100644
index 0000000..d23af12
--- /dev/null
+++ b/recipes-wifi/wireless-regdb/wireless-regdb_2023.05.03.bb
@@ -0,0 +1,52 @@
+SUMMARY = "Wireless Central Regulatory Domain Database"
+HOMEPAGE = "https://wireless.wiki.kernel.org/en/developers/regulatory/crda"
+SECTION = "net"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
+
+SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
+SRC_URI[sha256sum] = "f254d08ab3765aeae2b856222e11a95d44aef519a6663877c71ef68fae4c8c12"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/patches:"
+require files/patches/patches.inc
+
+inherit bin_package allarch pythonnative
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_install_prepend() {
+    (python ${S}/db2fw.py ${S}/regulatory.db ${S}/db.txt)
+}
+
+do_install() {
+    install -d -m0755 ${D}${nonarch_libdir}/crda
+    install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
+    install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
+    install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
+
+    install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
+    install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
+}
+
+# Install static regulatory DB in /lib/firmware for kernel to load.
+# This requires Linux kernel >= v4.15.
+# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass
+# (in meta-networking) in kernel's recipe.
+PACKAGES = "${PN}-static ${PN}"
+RCONFLICTS:${PN} = "${PN}-static"
+
+FILES:${PN}-static = " \
+    ${nonarch_base_libdir}/firmware/regulatory.db \
+    ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
+"
+
+# Native users might want to use the source of regulatory DB.
+# This is for example used by Linux kernel <= v4.14 and
+# kernel_wireless_regdb.bbclass in meta-networking.
+do_install:append:class-native() {
+    install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
+}
+
+RSUGGESTS:${PN} = "crda"
+
+BBCLASSEXTEND = "native"