[rdkb][common][hal][Refactor halinterface bbapend]

[Description]
Refactor halinterface bbapend
1. define wifi_getRadioDfsAtBootUpEnable and wifi_setRadioDfsAtBootUpEnable in wifi_hal_radio.h

[Release-log]

diff --git a/recipes-ccsp/hal/halinterface.bbappend b/recipes-ccsp/hal/halinterface.bbappend
index 8f87a99..9f18553 100644
--- a/recipes-ccsp/hal/halinterface.bbappend
+++ b/recipes-ccsp/hal/halinterface.bbappend
@@ -1,11 +1,14 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://sta-network.patch;apply=no"
+SRC_URI += "file://sta-network.patch;apply=no \
+		file://add_undefined_dfs_function.patch;apply=no \
+	"
 
 #This is workaround for missing do_patch when RDK uses external sources
 do_filogic_patches() {
     cd ${S}
         if [ ! -e patch_applied ]; then
             patch -p1 < ${WORKDIR}/sta-network.patch
+            patch -p1 < ${WORKDIR}/add_undefined_dfs_function.patch
             touch patch_applied
         fi
 }