[rdkb][common][bsp][Refactor and sync kernel from openwrt]
[Description]
c642b937 [kernel][common][hnat][Fix BIND entry with DP=0 issue for Wifi Tx]
ed76ee89 [openwrt][mt7988][crypto][Fix neigh_output parameters for IPSec inline mode]
24d49512 [MAC80211][WED][Fix wdma rx hang on wed1 after SER]
8caa9f50 [openwrt][common][net][Bypass seq check of pptp data packets]
48ef0810 [kernel][common][eth][Fix rcu_sched detected stall issue during LRO stress test]
53587858 [kernel][common][eth][Correct ring buffer allocation for the LRO]
094dfc87 [openwrt][mt7988][crypto][Refactor tport setting for packets to EIP197]
60822c70 [kernel][common][hnat][Increase the field width of the SW_UDF]
8889384e [kernel][common][eth][Add Airoha AN8801SB 1G PHY driver v1.1.0]
5b3b005d [kernel][common][thermal][Remove unused cooling device node in dts]
d7a3043c [kernel][mt7988][eth][macsec: Add correct clock selection]
aa999785 [kernel][mt7988][hnat][Add ipv6, 3PPE, wmb function to PPE static mode]
53a4535d [[openwrt][kernel][common][eth][feature support] update eth error reset detect condition]
9e8e84ea [kernel][common][pwm][Remove unused cell of pwm in dts]
1f80973b [kernel][common][pwm][Add pwm-gpio driver to Kconfig and Makefile]
1a579c58 [kernel][common][pwm][Add pwm-gpio as software pwm]
416ffc88 [openwrt][common][Fix build error in libkcapi]
de2c5d47 [kernel][common][Backport jitterrng to 2.2.0]
c1ac9fe9 [kernel][mt7988][eth][Update panic issue during SER test on the 4GB RFB]
317dcec1 [kernel][common][eth][Fix panic issue for the RX ring debug command]
3bb89973 [kernel][common][eth][Add a link down recovery handler for the SGMII]
c3853a9b [kernel][mt7988][eth][Add FE_CDM7_FSM and FE_GDM3_FSM to the dbg_regs command]
99977fc5 [kernel][common][Refactor network backport patch path]
a2610487 [MAC80211][hnat][Update multiple PPE allocation of the ETH for mt7988]
b1c06e45 [kernel][mt7988][eth][Fix panic issue during SER test on the 4GB RFB]
6dfdee52 [kernel][mt7988][hnat][Fix issue of HQoS not enable when used with NAT66]
d3e7752e [Add macsec HW offload backport from kernel 5.18]
9364c06f [kernel][common][eth][Fix Coverity scan warning]
15fa60ae [kernel][common][Revert jitterrng2.2.0 patch]
6df70da4 [MAC80211][hnat][Update IPv6 unbind issue for the routing mode]
[Release-log]
Change-Id: I834f8789e75ce9be3de0423aede5be7da8c84e82
diff --git a/recipes-kernel/linux/linux-mediatek_5.4.bb b/recipes-kernel/linux/linux-mediatek_5.4.bb
index dde2f00..18f0553 100644
--- a/recipes-kernel/linux/linux-mediatek_5.4.bb
+++ b/recipes-kernel/linux/linux-mediatek_5.4.bb
@@ -96,11 +96,12 @@
patch -p1 < ${WORKDIR}/001-rdkb-eth-mtk-change-ifname-for.patch
patch -p1 < ${WORKDIR}/003-rdkb-mtd-kernel-ubi-relayout.patch
patch -p1 < ${WORKDIR}/0600-net-phylink-propagate-resolved-link-config-via-mac_l.patch
+ patch -p1 < ${WORKDIR}/999-1050-v6.4-backport-jitterrng-2.2.0.patch
patch -p1 < ${WORKDIR}/999-2713-mt7531-gsw-internal_phy_calibration.patch
patch -p1 < ${WORKDIR}/999-2714-mt7531-gsw-port5_external_phy_init.patch
- patch -p1 < ${WORKDIR}/999-2721-net-mt753x-phy-coverity-scan.patch
- patch -p1 < ${WORKDIR}/999-1710-net-phy-add-phylink-pcs-support.patch
- patch -p1 < ${WORKDIR}/999-1712-net-phy-add-phylink-rate-matching-support.patch
+ patch -p1 < ${WORKDIR}/999-2737-net-mt753x-phy-coverity-scan.patch
+ patch -p1 < ${WORKDIR}/999-1710-v6.2-net-phy-add-phylink-pcs-support.patch
+ patch -p1 < ${WORKDIR}/999-1712-v6.2-net-phy-add-phylink-rate-matching-support.patch
patch -p1 < ${WORKDIR}/999-2702-v5.9-net-phy-add-support-for-a-common-probe-between-shared-PHYs.patch
patch -p1 < ${WORKDIR}/999-2725-iwconfig-wireless-rate-fix.patch
patch -p1 < ${WORKDIR}/999-2729-net-phy-remove-reporting-line-rate-to-mac.patch