[Add usteer support from OpenWRT]

[Description]
Add usteer support from OpenWRT
1. Also add libnl-tiny bb to support usteer

[Release-log]
N/A

diff --git a/recipes-connectivity/libnl-tiny/libnl-tiny_git.bb b/recipes-connectivity/libnl-tiny/libnl-tiny_git.bb
new file mode 100644
index 0000000..f35921a
--- /dev/null
+++ b/recipes-connectivity/libnl-tiny/libnl-tiny_git.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "This package contains a stripped down version of libnl"
+HOMEPAGE = "https://git.openwrt.org/?p=project/libnl-tiny.git;a=summary"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://nl.c;startline=4;endline=7;md5=f16bd5d25e622bb3001bab76be1f9f91"
+SECTION = "libs"
+
+SRC_URI = "git://git.openwrt.org/project/libnl-tiny.git"
+SRCREV = "b5b2ba09c4f1c8b3c21580aea7223edc2f5e92be"
+PV = "git${SRCPV}"
+
+inherit cmake pkgconfig
+S = "${WORKDIR}/git"
+
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${libdir}/*.so"