[Add kernel in UBI feature]

[Description]
Add kernel in UBI feature
1. create factory and sysupgrade image align to openwrt
2. align openwrt image framework: kernel in UBI and rootfs is squashfs format
3. remove the partition patch for dts
4. enable CONFIG_XZ_DEC_ARM in kernel to fix squashfs xz decompression
fail issue

[Release-log]

diff --git a/recipes-kernel/linux/linux-mediatek_5.4.bb b/recipes-kernel/linux/linux-mediatek_5.4.bb
index 4877f37..7bcc946 100644
--- a/recipes-kernel/linux/linux-mediatek_5.4.bb
+++ b/recipes-kernel/linux/linux-mediatek_5.4.bb
@@ -37,6 +37,7 @@
     file://rdkb_cfg/openvswitch.cfg \
     file://rdkb_cfg/mac80211.cfg \
     file://rdkb_cfg/prplmesh.cfg \
+    file://rdkb_cfg/filogic_rdkb.cfg \
 "
 require ${PN}-${PV}/generic/backport-5.4/backport-5.4.inc
 
@@ -68,7 +69,7 @@
     cd ${S}
         if [ ! -e patch_applied ]; then
             patch -p1 < ${WORKDIR}/001-rdkb-eth-mtk-change-ifname-for.patch
-            patch -p1 < ${WORKDIR}/002-rdkb-mtd-ubi-relayout.patch
+            
             patch -p1 < ${WORKDIR}/0600-net-phylink-propagate-resolved-link-config-via-mac_l.patch
             patch -p1 < ${WORKDIR}/9010-iwconfig-wireless-rate-fix.patch
             touch patch_applied