[Fix build error when using openwrt docker]

[Description]
Fix build error when using openwrt docker
1. Although openwrt docker has installed depmod, but it seems can't use it in docker, so force to apply the patch.

[Release-log]

diff --git a/recipes-kernel/linux-mac80211/linux-mac80211.bb b/recipes-kernel/linux-mac80211/linux-mac80211.bb
index b1f3be0..26dff46 100644
--- a/recipes-kernel/linux-mac80211/linux-mac80211.bb
+++ b/recipes-kernel/linux-mac80211/linux-mac80211.bb
@@ -32,7 +32,7 @@
 
 do_filogic_patches() {
     cd ${S}
-    if [ ! -e "/sbin/depmod" ] && [ ! -e patch_applied ]; then
+    if [ ! -e patch_applied ]; then
         patch -p1 < ${WORKDIR}/0001-rdkb-fix_build_issue-mac80211-without_depmod.patch
         touch patch_applied
     fi