[Refactoer add ccsp hal to meta-filogic]

[Description]
Refactoer add ccsp hal to meta-filogic

[Release-log]

diff --git a/recipes-ccsp/hal/hal-platform-generic_git.bbappend b/recipes-ccsp/hal/hal-platform-generic_git.bbappend
new file mode 100644
index 0000000..be61467
--- /dev/null
+++ b/recipes-ccsp/hal/hal-platform-generic_git.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "git://gerrit.mediatek.inc/gateway/rdk-b/rdkb_hal;protocol=https;destsuffix=git/source/platform/rdkb_hal"
+
+
+SRCREV = "${AUTOREV}"
+
+DEPENDS += "utopia-headers"
+CFLAGS_append = " \
+    -I=${includedir}/utctx \
+"
+
+do_configure_prepend(){
+    rm ${S}/platform_hal.c
+    ln -sf ${S}/rdkb_hal/src/platform/platform_hal.c ${S}/platform_hal.c
+}
\ No newline at end of file