[rdkb][common][bsp][Refactor and sync wifi from openwrt]

[Description]
05a67730 [mac80211][mt76][wifi6][do not report ACK when TXS is lost]
0bae31b5 [Fix WiFi7 Release Build Fail]
7bf748ba [openwrt-24][Mac80211][Fix Mozart build fail]
b52c9c66 [mac80211][mt76][wifi6][delete twt flow before remove stations]
7c4179d9 [mac8021][core][wifi6][set IEEE80211_TX_CTL_USE_MINRATE when probing]
8d17b91d [MAC80211][WiFi6][TWT][refine twt mcu update flow]
6d5ab74e [MAC80211][WiFi6][mt76][fix mt76 Makefile patch failed]
c6eeb297 [MAC80211][WiFi7][Misc][Fix release build fail because of mt76 version upgradation]
4df78532 [MAC80211][WiFi6][mt76][Fix TX/RX hang and SER hw bit didn't detect issue]

[Release-log]

Change-Id: I78f985181c5b667036461de240eec86e3912f431
diff --git a/recipes-wifi/wireless-regdb/wireless-regdb_2024.10.07.bb b/recipes-wifi/wireless-regdb/wireless-regdb_2024.10.07.bb
new file mode 100644
index 0000000..239054b
--- /dev/null
+++ b/recipes-wifi/wireless-regdb/wireless-regdb_2024.10.07.bb
@@ -0,0 +1,52 @@
+SUMMARY = "Wireless Central Regulatory Domain Database"
+HOMEPAGE = "https://wireless.wiki.kernel.org/en/developers/regulatory/crda"
+SECTION = "net"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
+
+SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
+SRC_URI[sha256sum] = "f76f2bd79a653e9f9dd50548d99d03a4a4eb157da056dfd5892f403ec28fb3d5"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/patches:"
+require files/patches/patches.inc
+
+inherit bin_package allarch ${@bb.utils.contains("DISTRO_FEATURES", "kirkstone", "python3native", "pythonnative", d)}
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_install_prepend() {
+    (python ${S}/db2fw.py ${S}/regulatory.db ${S}/db.txt)
+}
+
+do_install() {
+    install -d -m0755 ${D}${nonarch_libdir}/crda
+    install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
+    install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
+    install -m 0644 wens.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/wens.key.pub.pem
+
+    install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
+    install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
+}
+
+# Install static regulatory DB in /lib/firmware for kernel to load.
+# This requires Linux kernel >= v4.15.
+# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass
+# (in meta-networking) in kernel's recipe.
+PACKAGES = "${PN}-static ${PN}"
+RCONFLICTS:${PN} = "${PN}-static"
+
+FILES:${PN}-static = " \
+    ${nonarch_base_libdir}/firmware/regulatory.db \
+    ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
+"
+
+# Native users might want to use the source of regulatory DB.
+# This is for example used by Linux kernel <= v4.14 and
+# kernel_wireless_regdb.bbclass in meta-networking.
+do_install:append:class-native() {
+    install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
+}
+
+RSUGGESTS:${PN} = "crda"
+
+BBCLASSEXTEND = "native"