[rdkb][common][bsp][Refactor and sync kernl from openwrt]

[Description]
371e2ed [kernel][common][eth][Add phylink_pcs support for the SGMII/USXGMII]
e7f06c4 [MAC80211][wed][remove wed rx_drv interrupt]
ea09f72 [MAC80211][hnat][Fix DL floodind issue for the C50 UDP BiDi test]
619bce8 [kernel][mt7986][spi][spi-calibration: Fix probe flow error if flash devices don't need calibration]
c9239e3 [kernel][mt7986][spim][dts: Fix SPIM-NAND/NOR max frequency]
63cebb7 [kernel][mt7986][spi][spi-calibration: Add support for 4B mode NOR flashes]
889cfec [kernel][common][eth][Fix CISCO FET-10G SFP+ IOT issue]

[Release-log]

Change-Id: I9c01ed134f843403614182575be97d694a028d25
diff --git a/recipes-kernel/linux/linux-mediatek_5.4.bb b/recipes-kernel/linux/linux-mediatek_5.4.bb
index d03088b..5c7b8b6 100644
--- a/recipes-kernel/linux/linux-mediatek_5.4.bb
+++ b/recipes-kernel/linux/linux-mediatek_5.4.bb
@@ -91,6 +91,7 @@
             patch -p1 < ${WORKDIR}/738-mt7531-gsw-internal_phy_calibration.patch
             patch -p1 < ${WORKDIR}/739-mt7531-gsw-port5_external_phy_init.patch
             patch -p1 < ${WORKDIR}/753-net-mt753x-phy-coverity-scan.patch
+            patch -p1 < ${WORKDIR}/757-net-phy-add-phylink-pcs-support.patch
             patch -p1 < ${WORKDIR}/9010-iwconfig-wireless-rate-fix.patch
             if [ $DISTRO_secure_boot_ENABLED = 'true' ]; then
                 patch -p1 < ${WORKDIR}/0404-mtdsplit-dm-verity.patch