[rdkb][common][bsp][Refactor and sync kernel from openwrt]

[Description]
30651f4f [kernel][common][eth][Refactor polling idle condition of the GDM/MAC FSM]
83ecb7ca [MAC80211][hnat][Correct maximum rate limit for the PPPQ]
f0e27f7c [HIGH][kernel][common][eth][Update Airoha AN8801SB 1G PHY driver from v1.1.0 to v1.1.3]
d024fef4 [kernel][mt7988][eth][Fix ADMAv2 Tx hang and low throughput issues]
40086c25 [HIGH][kernel][common][eth][Refactor the link down recovery handler for out-of-band devices used with USXGMII/SGMII]
506042e0 [kernel][common][eth][Add phylink pcs_enable and pcs_disable methods]
1219ad6b [HIGH][kernel][mt7988][eth][Fix software padding processing in Ethernet Tx path]
a7c93592 [kernel][common][hnat][Fix Issue of nf_conntrack statistics missing after read all_entry]
7d04444b [openwrt][mt7988][hnat][Change header guard in hnat.h]
01555ca6 [HIGH][kernel][common][eth][Fix HQoS is not functioning properly following the SER issue]
a4163a16 [kernel][mt7988][lvts][Add multiple thermal zones support]
34d82c33 [kernel][common][eth][Add individual polarity control to the SGMII]
6831cde2 [openwrt][mt7988][hnat][Add header guard in hnat.h]
701fc2e7 [[kernel][mt7988][eth][add SER path from wifi to eth]]
48284e92 [openwrt][mt7988][tops][refactor tops-tool and add logger suuport]
69ddea16 [kernel][common][eth][Refactor polling idle condition of the GDM/MAC FSM]
05f3c827 [openwrt][mt7988][app][Add utility for configuring Mxl series ethernet switchs]
19d8db9f [kernel][mt7988][eth][Add support for the permanent MAC address of the ethtool]
11095c23 [CRITICAL][kernel][common][eth][Add automatic firmware selection for Aquantia PHY]

[Release-log]

Change-Id: I4417986b3a2c0dd1d8e62846abc345464bbaffbc
diff --git a/recipes-kernel/linux/linux-mediatek_5.4.bb b/recipes-kernel/linux/linux-mediatek_5.4.bb
index 746a7dc..b3a4f9b 100644
--- a/recipes-kernel/linux/linux-mediatek_5.4.bb
+++ b/recipes-kernel/linux/linux-mediatek_5.4.bb
@@ -103,6 +103,7 @@
             patch -p1 < ${WORKDIR}/999-2737-net-mt753x-phy-coverity-scan.patch
             patch -p1 < ${WORKDIR}/999-1710-v6.2-net-phy-add-phylink-pcs-support.patch
             patch -p1 < ${WORKDIR}/999-1712-v6.2-net-phy-add-phylink-rate-matching-support.patch
+            patch -p1 < ${WORKDIR}/999-1716-v6.6-net-phy-add-phylink-pcs_enable-and-pcs_disable.patch
             patch -p1 < ${WORKDIR}/999-2725-iwconfig-wireless-rate-fix.patch
             patch -p1 < ${WORKDIR}/999-2729-net-phy-remove-reporting-line-rate-to-mac.patch
             patch -p1 < ${WORKDIR}/999-2739-drivers_net_ethernet_mediatek_hnat.patch