[Add SMP tool]

[Description]
Add SMP tool
1. add smp-mt76.sh
2. add smp.service for system in initial state to trigger smp-mt76.sh
once

[Release-log]

diff --git a/recipes-devtools/smp/smp_1.0.bb b/recipes-devtools/smp/smp_1.0.bb
new file mode 100644
index 0000000..ce7b2ba
--- /dev/null
+++ b/recipes-devtools/smp/smp_1.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "SMP IRQ Affinity tool"
+SECTION = "applications"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+S = "${WORKDIR}"
+inherit systemd
+
+SRC_URI = " \
+    file://COPYING \
+    file://smp-mt76.sh \
+    file://smp.service \
+    "
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = " smp.service"
+FILES_${PN} += "{systemd_unitdir}/system/smp.service"
+
+do_install() {
+    install -d ${D}${sbindir}
+    install -m 0755 ${WORKDIR}/smp-mt76.sh ${D}${sbindir}
+	install -d ${D}${systemd_unitdir}/system/
+	install -m 0644 ${S}/smp.service ${D}${systemd_unitdir}/system
+}